---
id: CVE-2026-93767
title: >-
  The Tainacan plugin for WordPress is vulnerable to Directory Traversal in all
  versions up to, and including, 1.3.0 via the 'guid' parameter parameter
summary: >-
  The Tainacan plugin for WordPress is vulnerable to Directory Traversal in all
  versions up to, and including, 1.3.0 via the 'guid' parameter parameter. This
  makes it possible for authenticated attackers, with subscriber-level access
  and a…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-22
vendor: tainacan
product: Tainacan
affected:
  - Tainacan <= 1.3.0
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T16:22:43.780'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-93767'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/tainacan/tags/1.3.0/classes/api/endpoints/class-tainacan-rest-background-processes-controller.php#L147
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/tainacan/tags/1.3.0/classes/api/endpoints/class-tainacan-rest-background-processes-controller.php#L391
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/tainacan/tags/1.3.0/classes/api/endpoints/class-tainacan-rest-background-processes-controller.php#L393
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/tainacan/tags/1.3.0/classes/api/endpoints/class-tainacan-rest-background-processes-controller.php#L418
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3733197%40tainacan&new=3733197%40tainacan
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/4ff75bf6-c8c3-43f5-bc71-0e54e892e664?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00567
epssPercentile: 0.46834
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T15:44:24.334833Z'
ingestedAt: '2026-10-16T06:00:00.393Z'
---

## Overview

The Tainacan plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 1.3.0 via the 'guid' parameter parameter. This makes it possible for authenticated attackers, with subscriber-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information. This vulnerability is exploitable only when the uploads/tainacan directory does not exist on the server, as this condition causes realpath() to return false, collapsing the base path to an empty string and rendering the containment check ineffective.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
