---
id: CVE-2026-93851
title: >-
  Path traversal in Mattermost Agents plugin mention reminder allows plugin
  replacement via crafted post
summary: >-
  Mattermost versions 11.9.x <= 11.9.1, 11.8.x <= 11.8.5, 11.7.x <= 11.7.10 fail
  to validate the target post ID in the Agents plugin's mention reminder
  component, which allows an authenticated user who can post in a channel
  visible to a sy…
severity: high
cvss: 8
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-22
vendor: Mattermost
product: Mattermost
affected:
  - Mattermost >= 11.9.0 <= 11.9.1
  - Mattermost >= 11.8.0 <= 11.8.5
  - Mattermost >= 11.7.0 <= 11.7.10
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-29T00:00:00+00:00'
published: '2026-10-28'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T03:56:14.074Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-93851'
references:
  - url: 'https://mattermost.com/security-updates'
    label: MMSA-2026-00742
tags:
  - cve.org
epss: 0.00266
epssPercentile: 0.18882
ingestedAt: '2026-11-03T10:42:03.625Z'
---

## Overview

Mattermost versions 11.9.x <= 11.9.1, 11.8.x <= 11.8.5, 11.7.x <= 11.7.10 fail to validate the target post ID in the Agents plugin's mention reminder component, which allows an authenticated user who can post in a channel visible to a system administrator to cause the administrator's browser to send an unintended API request, resulting in replacement of an installed plugin and code execution on the server, via a crafted post containing a forged mention reminder that the administrator clicks. Mattermost Advisory ID: MMSA-2026-00742

## Affected

- `Mattermost >= 11.9.0 <= 11.9.1`
- `Mattermost >= 11.8.0 <= 11.8.5`
- `Mattermost >= 11.7.0 <= 11.7.10`

## Remediation

Update Mattermost to versions 11.10.0, 11.9.2, 11.8.6, 11.7.11 or higher.
