---
id: CVE-2026-93855
title: >-
  SendPress Newsletters <= 1.26.1.20 - Unauthenticated SQL Injection via
  'subscriberid' Parameter
summary: >-
  The SendPress Newsletters plugin for WordPress is vulnerable to time-based SQL
  Injection via the 'subscriberid' parameter in all versions up to, and
  including, 1.26.1.20 due to insufficient escaping on the user supplied
  parameter and lac…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cvssSource: cna
cwe:
  - CWE-89
vendor: brewlabs
product: SendPress Newsletters
affected:
  - sendpress_newsletters <= 1.26.1.20
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-29T10:32:52.850610Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T10:45:42.961Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-93855'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/6b562f31-6a57-4719-a0e1-6a92affef844?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/sendpress/tags/1.26.1.20/classes/class-sendpress-data.php#L1300
  - url: >-
      https://plugins.trac.wordpress.org/browser/sendpress/tags/1.26.1.20/classes/sc/class-sendpress-sc-forms.php#L580
tags:
  - cve.org
epss: 0.00411
epssPercentile: 0.35365
ingestedAt: '2026-10-31T05:18:25.269Z'
---

## Overview

The SendPress Newsletters plugin for WordPress is vulnerable to time-based SQL Injection via the 'subscriberid' parameter in all versions up to, and including, 1.26.1.20 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. The nonce gating the handler uses the hardcoded action value 'sendpress-is-awesome', which is rendered on the same public page served by the [sp-form formid="manage"] shortcode, making it trivially obtainable by unauthenticated visitors and effectively bypassing the nonce as an access control.

## Affected

- `sendpress_newsletters <= 1.26.1.20`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
