---
id: CVE-2026-93900
title: >-
  Simple CAPTCHA with Cloudflare Turnstile <= 1.44.3 - Authenticated
  (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes
summary: >-
  The Simple CAPTCHA with Cloudflare Turnstile plugin for WordPress is
  vulnerable to Stored Cross-Site Scripting via the 'id' attribute of the
  [gravity-simple-turnstile] shortcode in versions up to, and including, 1.44.3
  This is due to ins…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: elliotvs
product: Simple CAPTCHA with Cloudflare Turnstile
affected:
  - simple_captcha_with_cloudflare_turnstile <= 1.44.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-04T20:12:43.877175Z'
published: '2026-11-04'
updated: '2026-11-04'
sourceUpdated: '2026-11-04T20:14:23.468Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-93900'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/056a6984-4753-4f52-87b0-1a3cc2f5bde2?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/simple-cloudflare-turnstile/tags/1.43.1/inc/integrations/forms/gravity-forms.php#L22
  - url: >-
      https://plugins.trac.wordpress.org/browser/simple-cloudflare-turnstile/tags/1.43.1/inc/integrations/forms/gravity-forms.php#L13
  - url: >-
      https://plugins.trac.wordpress.org/browser/simple-cloudflare-turnstile/tags/1.41.0/inc/integrations/forms/gravity-forms.php#L22
  - url: >-
      https://plugins.trac.wordpress.org/browser/simple-cloudflare-turnstile/tags/1.41.0/inc/integrations/forms/gravity-forms.php#L13
  - url: 'https://plugins.trac.wordpress.org/browser/simple-cloudflare-turnstile/'
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3776057/simple-cloudflare-turnstile/trunk/inc/integrations/forms/gravity-forms.php
tags:
  - cve.org
epss: 0.00334
epssPercentile: 0.26939
ingestedAt: '2026-11-05T21:36:00.536Z'
---

## Overview

The Simple CAPTCHA with Cloudflare Turnstile plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'id' attribute of the [gravity-simple-turnstile] shortcode in versions up to, and including, 1.44.3 This is due to insufficient input sanitization and output escaping on the shortcode attribute in the cfturnstile_gravity_shortcode() function: the value is filtered only by esc_html() and sanitize_text_field() (neither of which touches parentheses or dots) and then emitted via esc_js() in a raw JavaScript expression context outside any string literal (esc_js only escapes quotes, backslashes, and newlines). This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Affected

- `simple_captcha_with_cloudflare_turnstile <= 1.44.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
