---
id: CVE-2026-94169
title: >-
  Improper Control of Generation of Code ('Code Injection') vulnerability in
  Theme-one The Grid the-grid allows Command Injection.This issue affects The
  Grid: from n/a through 2.8.1.
summary: >-
  Improper Control of Generation of Code ('Code Injection') vulnerability in
  Theme-one The Grid the-grid allows Command Injection.This issue affects The
  Grid: from n/a through 2.8.1.
severity: critical
cvss: 10
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H'
cwe:
  - CWE-94
vendor: Theme-one
product: the-grid
affected:
  - the-grid <= 2.8.1
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:19:36.177'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-94169'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/the-grid/vulnerability/wordpress-the-grid-plugin-2-8-1-remote-code-execution-rce-vulnerability?_s_id=cve
    label: audit@patchstack.com
tags:
  - nvd
  - exploit-available
  - cve.org
epss: 0.04422
epssPercentile: 0.91308
exploits:
  github: 1
  githubRepos:
    - 'https://github.com/kize7/CVE-2026-94169'
  nuclei:
    - CVE-2026-94169
  checkedAt: '2026-10-27T18:52:45.386Z'
exploitAvailable: true
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-16T14:19:37.498695Z'
ingestedAt: '2026-10-16T08:02:23.124Z'
---

## Overview

Improper Control of Generation of Code ('Code Injection') vulnerability in Theme-one The Grid the-grid allows Command Injection.This issue affects The Grid: from n/a through 2.8.1.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
