---
id: CVE-2026-94171
title: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in VillaTheme CURCY woo-multi-currency allows
  DOM-Based XSS.This issue affects CURCY: 2.2.18.
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in VillaTheme CURCY woo-multi-currency allows
  DOM-Based XSS.This issue affects CURCY: 2.2.18.
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'
cwe:
  - CWE-79
vendor: VillaTheme
product: woo-multi-currency
affected:
  - woo-multi-currency >= 0.0.0 <= 2.2.16
  - woo-multi-currency 2.2.18
published: '2026-09-30'
updated: '2026-10-05'
sourceUpdated: '2026-10-05T14:17:21.483'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-94171'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/woo-multi-currency/vulnerability/wordpress-curcy-plugin-2-2-16-cross-site-scripting-xss-vulnerability?_s_id=cve
    label: audit@patchstack.com
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-09-30T17:58:29.042698Z'
epss: 0.00142
epssPercentile: 0.03468
ingestedAt: '2026-09-30T18:17:24.527Z'
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VillaTheme CURCY woo-multi-currency allows DOM-Based XSS.This issue affects CURCY: 2.2.18.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
