---
id: CVE-2026-94197
title: >-
  An authentication and authorization bypass vulnerability exists in F5 NGINX
  Kubernetes Ingress Controller (NIC) when configured with the `ExternalAuth`
  policy or Ingress external authentication
summary: >-
  An authentication and authorization bypass vulnerability exists in F5 NGINX
  Kubernetes Ingress Controller (NIC) when configured with the `ExternalAuth`
  policy or Ingress external authentication. Client-supplied X-Forwarded-Prefix,
  X-Forw…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-290
vendor: F5
product: NGINX Ingress Controller
affected:
  - nginx_ingress_controller >= 5.5.0 < 5.7.0
published: '2026-10-14'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T17:17:32.343'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-94197'
references:
  - url: 'https://my.f5.com/manage/s/article/K000162611'
    label: f5sirt@f5.com
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-15T15:53:41.365707Z'
ingestedAt: '2026-10-14T15:36:14.033Z'
epss: 0.00394
epssPercentile: 0.33365
---

## Overview

An authentication and authorization bypass vulnerability exists in F5 NGINX Kubernetes Ingress Controller (NIC) when configured with the `ExternalAuth` policy or Ingress external authentication. Client-supplied X-Forwarded-Prefix, X-Forwarded-URI, X-Original-URI, and X-Forwarded-Method routing and method headers are forwarded unsanitized into the internal authentication subrequest (handled by the NGINX auth_request directive). As a result, an unauthenticated, remote attacker may spoof request attributes evaluated by the external authentication provider. 

Impact:
This vulnerability may allow remote attackers 

unauthenticated

 access to protected 

paths. There is no control plane exposure; this is a data plane issue only.




Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
