---
id: CVE-2026-94238
title: >-
  The Loco Translate WordPress plugin before 2.8.9 does not restrict which file
  paths its translation file routes will read, allowing users granted the Loco
  Translate WordPress plugin before 2.8.9's translator capability to retrieve
  the co…
summary: >-
  The Loco Translate WordPress plugin before 2.8.9 does not restrict which file
  paths its translation file routes will read, allowing users granted the Loco
  Translate WordPress plugin before 2.8.9's translator capability to retrieve
  the co…
severity: medium
cvss: 6.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N'
cwe:
  - CWE-22
product: Loco Translate
affected:
  - loco_translate < 2.8.9
published: '2026-10-03'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T15:18:12.170'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-94238'
references:
  - url: 'https://wpscan.com/vulnerability/76d339bf-094c-459d-9f6c-caeda5e97892/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
epss: 0.00316
epssPercentile: 0.24697
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-03T15:00:18.887009Z'
ingestedAt: '2026-10-03T06:39:57.568Z'
---

## Overview

The Loco Translate WordPress plugin before 2.8.9 does not restrict which file paths its translation file routes will read, allowing users granted the Loco Translate WordPress plugin before 2.8.9's translator capability to retrieve the contents of files of certain types from anywhere on the server, including outside the web root.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
