---
id: CVE-2026-94239
title: >-
  The Loco Translate WordPress plugin before 2.8.9 does not sanitise and escape
  some bundle configuration values before outputting them back in an admin page,
  allowing users with the translator capability and above to perform Stored
  Cross-…
summary: >-
  The Loco Translate WordPress plugin before 2.8.9 does not sanitise and escape
  some bundle configuration values before outputting them back in an admin page,
  allowing users with the translator capability and above to perform Stored
  Cross-…
severity: medium
cvss: 6.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-79
product: Loco Translate
affected:
  - loco_translate < 2.8.9
published: '2026-10-03'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T15:18:12.170'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-94239'
references:
  - url: 'https://wpscan.com/vulnerability/6ab3ec44-cf3b-43ac-8c84-51291e9759dc/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
epss: 0.00229
epssPercentile: 0.13582
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-03T15:00:07.216675Z'
ingestedAt: '2026-10-03T06:39:57.568Z'
---

## Overview

The Loco Translate WordPress plugin before 2.8.9 does not sanitise and escape some bundle configuration values before outputting them back in an admin page, allowing users with the translator capability and above to perform Stored Cross-Site Scripting attacks against high privilege users such as administrators.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
