---
id: CVE-2026-94244
title: >-
  The Wallet System for WooCommerce  WordPress plugin before 2.8.0 does not
  perform any capability check, and relies on a token any authenticated user can
  obtain from a front-end page, before generating a report containing every
  customer's…
summary: >-
  The Wallet System for WooCommerce  WordPress plugin before 2.8.0 does not
  perform any capability check, and relies on a token any authenticated user can
  obtain from a front-end page, before generating a report containing every
  customer's…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N'
cwe:
  - CWE-200
product: Wallet System for WooCommerce
affected:
  - wallet_system_for_woocommerce < 2.8.0
published: '2026-10-08'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T20:51:18.123'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-94244'
references:
  - url: 'https://wpscan.com/vulnerability/991f28f3-9cd8-4918-8431-a063eb2ba536/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-08T10:55:01.002331Z'
ingestedAt: '2026-10-08T07:18:54.842Z'
epss: 0.00176
epssPercentile: 0.07101
---

## Overview

The Wallet System for WooCommerce  WordPress plugin before 2.8.0 does not perform any capability check, and relies on a token any authenticated user can obtain from a front-end page, before generating a report containing every customer's wallet transaction history, allowing any authenticated user, such as a subscriber, to disclose all users' names, email addresses, roles, transaction amounts, payment methods and dates.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
