---
id: CVE-2026-94245
title: >-
  The Wallet System for WooCommerce  WordPress plugin before 2.8.0 does not
  verify that the user submitting a wallet transfer owns the wallet being
  debited, allowing any authenticated user, including one with only the
  Subscriber role, to m…
summary: >-
  The Wallet System for WooCommerce  WordPress plugin before 2.8.0 does not
  verify that the user submitting a wallet transfer owns the wallet being
  debited, allowing any authenticated user, including one with only the
  Subscriber role, to m…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N'
cwe:
  - CWE-639
product: Wallet System for WooCommerce
affected:
  - wallet_system_for_woocommerce >= 2.0.0 < 2.8.0
published: '2026-10-08'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T20:51:18.123'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-94245'
references:
  - url: 'https://wpscan.com/vulnerability/fd44c88d-2ca4-4e3d-9e9f-570e239df4bd/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-08T10:54:51.979486Z'
ingestedAt: '2026-10-08T07:18:54.843Z'
epss: 0.00174
epssPercentile: 0.06874
---

## Overview

The Wallet System for WooCommerce  WordPress plugin before 2.8.0 does not verify that the user submitting a wallet transfer owns the wallet being debited, allowing any authenticated user, including one with only the Subscriber role, to move an arbitrary user's wallet balance, including an administrator's, into an account they control.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
