---
id: CVE-2026-95634
title: >-
  CAI Content Credentials is affected by a Server-Side Request Forgery (SSRF)
  vulnerability that could result in privilege escalation
summary: >-
  CAI Content Credentials is affected by a Server-Side Request Forgery (SSRF)
  vulnerability that could result in privilege escalation. Exploitation of this
  issue does not require user interaction. Scope is changed.
severity: high
cvss: 8.6
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N'
cwe:
  - CWE-918
vendor: adobe
product: c2pa
affected:
  - c2pa < 0.91.1
  - c2pa-web < 0.15.3
  - c2patool < 0.28.1
patched:
  - c2pa 0.91.1
  - c2pa-web 0.15.3
  - c2patool 0.28.1
published: '2026-10-13'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T18:42:11.487'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-95634'
references:
  - url: >-
      https://www.adobe.com/trust/security/products/content-credentials-sdk/apsb26-163.html
    label: psirt@adobe.com
tags:
  - nvd
  - cve.org
epss: 0.00519
epssPercentile: 0.43886
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-14T14:39:35.737280Z'
ingestedAt: '2026-10-13T23:03:54.752Z'
---

## Overview

CAI Content Credentials is affected by a Server-Side Request Forgery (SSRF) vulnerability that could result in privilege escalation. Exploitation of this issue does not require user interaction. Scope is changed.

## Affected

- `c2pa < 0.91.1`
- `c2pa-web < 0.15.3`
- `c2patool < 0.28.1`

## Remediation

Upgrade past the affected range:

- `c2pa 0.91.1`
- `c2pa-web 0.15.3`
- `c2patool 0.28.1`
