---
id: CVE-2026-95695
title: >-
  IBM WebSphere Application Server - Liberty 20.0.0.12 through 26.0.0.10 could
  allow a remote attacker to bypass security restrictions due to incorrect
  authorization.
summary: >-
  IBM WebSphere Application Server - Liberty 20.0.0.12 through 26.0.0.10 could
  allow a remote attacker to bypass security restrictions due to incorrect
  authorization.
severity: high
cvss: 7.4
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N'
cwe:
  - CWE-863
published: '2026-10-13'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T17:20:22.157'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-95695'
references:
  - url: 'https://www.ibm.com/support/pages/node/7292228'
    label: psirt@us.ibm.com
tags:
  - nvd
  - cve.org
epss: 0.00323
epssPercentile: 0.25207
ingestedAt: '2026-10-13T21:58:14.200Z'
vendor: IBM
product: WebSphere Application Server - Liberty
affected:
  - websphere_application_server_-_liberty >= 20.0.0.12 <= 26.0.0.10
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-14T16:57:35.636013Z'
---

## Overview

IBM WebSphere Application Server - Liberty 20.0.0.12 through 26.0.0.10 could allow a remote attacker to bypass security restrictions due to incorrect authorization.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
