---
id: CVE-2026-95736
title: >-
  Unauthenticated Adjacent Improper Certificate Validation Vulnerabilities in
  HPE Networking Fabric Composer
summary: >-
  Improper certificate validation vulnerabilities exist in the affected
  interface of HPE Networking Fabric Composer, which could be exploited by an
  unauthenticated adjacent attacker if certain preconditions outside of the
  attacker's contro…
severity: high
cvss: 8.3
cvssVector: 'CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H'
cvssSource: cna
vendor: Hewlett Packard Enterprise (HPE)
product: Fabric Composer
affected:
  - fabric_composer >= 7.4.0 <= 7.4.0
  - fabric_composer >= 7.0.0 <= 7.3.4
published: '2026-11-03'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T19:50:53.587Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-95736'
references:
  - url: >-
      https://support.hpe.com/hpesc/public/docDisplay?docId=hpesbnw05172en_us&docLocale=en_US
tags:
  - cve.org
epss: 0.00102
epssPercentile: 0.00921
ingestedAt: '2026-11-05T20:33:06.406Z'
---

## Overview

Improper certificate validation vulnerabilities exist in the affected interface of HPE Networking Fabric Composer, which could be exploited by an unauthenticated adjacent attacker if certain preconditions outside of the attacker's control are met. Successful exploitation could allow an attacker to intercept sensitive information.

## Affected

- `fabric_composer >= 7.4.0 <= 7.4.0`
- `fabric_composer >= 7.0.0 <= 7.3.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
