---
id: CVE-2026-96562
title: >-
  The The Broken Link Checker plugin for WordPress is vulnerable to arbitrary
  shortcode execution in all versions up to, and including, 2.4.14.1
summary: >-
  The The Broken Link Checker plugin for WordPress is vulnerable to arbitrary
  shortcode execution in all versions up to, and including, 2.4.14.1. This is
  due to the software allowing users to execute an action that does not properly
  valida…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N'
cwe:
  - CWE-94
vendor: wpmudev
product: Broken Link Checker
affected:
  - broken_link_checker <= 2.4.14.1
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:37.480'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-96562'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/broken-link-checker/tags/2.4.14.1/legacy/includes/containers.php#L298
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/broken-link-checker/tags/2.4.14.1/legacy/modules/containers/comment.php#L229
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/broken-link-checker/tags/2.4.14.1/legacy/modules/parsers/html_link.php#L72
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/broken-link-checker/tags/2.4.14.1/legacy/modules/parsers/image.php#L66
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3740705%40broken-link-checker&new=3740705%40broken-link-checker
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/04cc4b99-8c27-4f95-b860-608c01af843b?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.0028
epssPercentile: 0.2036
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-16T14:51:04.245344Z'
ingestedAt: '2026-10-16T04:58:47.494Z'
---

## Overview

The The Broken Link Checker plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.4.14.1. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. Exploitation requires that a submitted comment containing the shortcode payload in an href or src attribute is approved through the site's normal comment moderation workflow; once approved, the shortcode is executed automatically via WP-Cron without any further attacker interaction.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
