---
id: CVE-2026-96741
title: >-
  DSGVO All in one for WP <= 5.0 - Unauthenticated Stored Cross-Site Scripting
  via Comment Content via Output Buffer Regex Corruption
summary: >-
  The DSGVO All in one for WP plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via Comment Content via Output Buffer Regex Corruption in
  all versions up to, and including, 5.0 due to insufficient input sanitization
  and out…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: mlfactory
product: DSGVO All in one for WP
affected:
  - dsgvo_all_in_one_for_wp <= 5.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T10:32:30.976506Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T10:45:43.246Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-96741'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/219b29a6-6148-4cc9-960c-b28f2d90236e?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/dsgvo-all-in-one-for-wp/tags/5.0/dsgvo_all_in_one_wp.php#L2909
  - url: >-
      https://plugins.trac.wordpress.org/browser/dsgvo-all-in-one-for-wp/tags/5.0/dsgvo_all_in_one_wp.php#L2901
  - url: >-
      https://plugins.trac.wordpress.org/browser/dsgvo-all-in-one-for-wp/tags/5.0/dsgvo_all_in_one_wp.php#L1611
tags:
  - cve.org
epss: 0.00236
epssPercentile: 0.14711
ingestedAt: '2026-10-31T05:18:25.271Z'
---

## Overview

The DSGVO All in one for WP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content via Output Buffer Regex Corruption in all versions up to, and including, 5.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when the administrator has enabled both the 'Google Tag Manager' integration and the 'Replace integration automatically [Beta]' option, and requires the crafted comment to be approved by an administrator.

## Affected

- `dsgvo_all_in_one_for_wp <= 5.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
