---
id: CVE-2026-96767
title: >-
  NEX-Forms <= 9.3.2 - Unauthenticated Stored Cross-Site Scripting via
  Content-Type Header
summary: >-
  The NEX-Forms – Ultimate Forms Plugin for WordPress plugin for WordPress is
  vulnerable to Stored Cross-Site Scripting via the 'type' parameter in all
  versions up to, and including, 9.3.2 due to insufficient input sanitization
  and output …
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: webaways
product: NEX-Forms – Ultimate Forms Plugin for WordPress
affected:
  - nex-forms_ultimate_forms_plugin_for_wordpress <= 9.3.2
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T12:17:31.113976Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T12:36:51.254Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-96767'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/1f80dc1b-2622-4cf5-9975-3609bfa21333?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/nex-forms-express-wp-form-builder/tags/9.3.2/includes/classes/class.dashboard.php#L4631
  - url: >-
      https://plugins.trac.wordpress.org/browser/nex-forms-express-wp-form-builder/tags/9.3.2/main.php#L2844
  - url: >-
      https://plugins.trac.wordpress.org/browser/nex-forms-express-wp-form-builder/tags/9.3.2/main.php#L3051
  - url: >-
      https://plugins.trac.wordpress.org/browser/nex-forms-express-wp-form-builder/tags/9.3.2/includes/classes/class.functions.php#L2341
  - url: >-
      https://plugins.trac.wordpress.org/browser/nex-forms-express-wp-form-builder/tags/9.3.2/main.php#L2684
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3755941%40nex-forms-express-wp-form-builder&new=3755941%40nex-forms-express-wp-form-builder
tags:
  - cve.org
epss: 0.00419
epssPercentile: 0.36197
ingestedAt: '2026-11-01T18:59:04.458Z'
---

## Overview

The NEX-Forms – Ultimate Forms Plugin for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'type' parameter in all versions up to, and including, 9.3.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Affected

- `nex-forms_ultimate_forms_plugin_for_wordpress <= 9.3.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
