---
id: CVE-2026-96870
title: >-
  The SureDash – Community, Courses & Member Dashboard plugin for WordPress is
  vulnerable to Stored Cross-Site Scripting via the 'display_name' parameter in
  all versions up to, and including, 1.12.0 due to insufficient input
  sanitization a…
summary: >-
  The SureDash – Community, Courses & Member Dashboard plugin for WordPress is
  vulnerable to Stored Cross-Site Scripting via the 'display_name' parameter in
  all versions up to, and including, 1.12.0 due to insufficient input
  sanitization a…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: brainstormforce
product: 'SureDash – Community, Courses & Member Dashboard'
affected:
  - suredash_community_courses_member_dashboard <= 1.12.0
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:37.933'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-96870'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/suredash/tags/1.12.0/assets/js/minified/common.min.js#L58
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/suredash/tags/1.12.0/core/routers/misc.php#L647
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/suredash/tags/1.12.0/core/routes.php#L121
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/suredash/tags/1.12.0/inc/functions/functions.php#L1037
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/suredash/tags/1.12.0/inc/functions/functions.php#L1111
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/suredash/tags/1.12.0/inc/services/router.php#L127
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&new=3721168%40suredash%2Ftags%2F1.12.1&old=3694773%40suredash%2Ftags%2F1.12.0
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/ece14f57-475d-4efc-8daf-52dfdaa12697?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.002
epssPercentile: 0.09709
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:14:41.455734Z'
ingestedAt: '2026-10-16T08:02:23.117Z'
---

## Overview

The SureDash – Community, Courses & Member Dashboard plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display_name' parameter in all versions up to, and including, 1.12.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit is triggered when any user hovers over a comment's like counter on a community page, as the plugin's tooltip handler assigns the attacker-controlled data-tooltip-description attribute value directly to innerHTML, re-parsing the browser-decoded entity payload as live HTML.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
