---
id: CVE-2026-96889
title: A flaw was found in librsvg
summary: >-
  A flaw was found in librsvg. When processing an SVG document containing nested
  XML inclusions (Xincludes) with duplicate entity declarations, a
  use-after-free error can occur. This vulnerability arises because the library
  incorrectly fre…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-416
vendor: Red Hat
product: glycin-loaders
affected:
  - glycin-loaders (all versions)
  - librsvg2 (all versions)
  - librsvg2
  - librsvg2 (all versions)
  - librsvg2 (all versions)
  - librsvg2 (all versions)
patched:
  - librsvg 2.63.2
published: '2026-09-23'
updated: '2026-09-25'
sourceUpdated: '2026-09-25T18:17:34.240'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-96889'
references:
  - url: 'https://access.redhat.com/security/cve/CVE-2026-96889'
    label: secalert@redhat.com
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2539279'
    label: secalert@redhat.com
  - url: 'https://crates.io/crates/librsvg'
    label: secalert@redhat.com
  - url: 'https://gitlab.gnome.org/GNOME/librsvg/-/work_items/1241'
    label: secalert@redhat.com
  - url: 'https://rustsec.org/advisories/RUSTSEC-2026-0305.html'
    label: secalert@redhat.com
  - url: 'https://gitlab.gnome.org/GNOME/librsvg/-/work_items/1241'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-96889.json
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-96889'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-96889'
  - url: 'https://access.redhat.com/errata/RHSA-2026:86331'
    label: 'RHSA-2026:86331'
  - url: 'https://access.redhat.com/errata/RHSA-2026:86841'
  - url: 'https://access.redhat.com/errata/RHSA-2026:86842'
  - url: 'https://access.redhat.com/errata/RHSA-2026:86921'
    label: 'RHSA-2026:86921'
  - url: >-
      https://github.com/GNOME/librsvg/commit/0bc935e675947e185d42005d3ad93d7cf61bcea9
  - url: >-
      https://github.com/GNOME/librsvg/commit/1606574427408baca8203ef723281509a229f9e2
  - url: >-
      https://github.com/GNOME/librsvg/commit/4d0051a9dbd038a5fe8461b61486677d88f8736d
  - url: >-
      https://github.com/GNOME/librsvg/commit/e56cc8a33a7184eef6e8a720414aee6205a400ad
  - url: 'https://gitlab.gnome.org/GNOME/librsvg/-/merge_requests/1211'
  - url: >-
      https://gitlab.gnome.org/GNOME/librsvg/-/commit/8a1b0cd319e9af2d1e9cf878081dd77f227a0504
  - url: 'https://github.com/GNOME/librsvg/releases/tag/2.63.2'
  - url: 'https://github.com/GNOME/librsvg/releases/tag/2.62.4'
  - url: 'https://github.com/GNOME/librsvg/releases/tag/2.61.5'
  - url: 'https://github.com/GNOME/librsvg/releases/tag/2.60.3'
  - url: 'https://github.com/GNOME/librsvg/releases/tag/2.57.5'
  - url: 'https://github.com/GNOME/librsvg/blob/2.63.2/NEWS'
  - url: 'https://github.com/advisories/GHSA-cpvr-w4j5-2mpg'
  - url: 'https://gitlab.gnome.org/GNOME/librsvg'
tags:
  - nvd
  - exploit-available
  - cve.org
  - osv
  - rust
  - csaf
  - vex
  - red-hat
  - ghsa
epss: 0.00529
epssPercentile: 0.4454
exploits:
  github: 5
  githubRepos:
    - 'https://github.com/rafabd1/VectorFreed'
    - 'https://github.com/lion9453/CVE-2026-96889-nextjs-rce'
    - 'https://github.com/pauleprichna/cybersecurity'
  checkedAt: '2026-10-27T19:24:41.165Z'
exploitAvailable: true
aliases:
  - RUSTSEC-2026-0305
  - GHSA-cpvr-w4j5-2mpg
ecosystem: rust
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-25T17:53:42.623078Z'
ingestedAt: '2026-09-23T20:32:10.757Z'
---

## Overview

A flaw was found in librsvg. When processing an SVG document containing nested XML inclusions (Xincludes) with duplicate entity declarations, a use-after-free error can occur. This vulnerability arises because the library incorrectly frees an XML entity that is still in use by the parser. An attacker could potentially exploit this to cause a denial of service or execute arbitrary code.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-96889)

Affected packages:

- `librsvg >= 2.62.90, < 2.63.2`

Patched in:

- `librsvg 2.63.2`

Source: https://osv.dev/vulnerability/RUSTSEC-2026-0305

## Vendor advisories

- **Red Hat VEX** · Important · affected: Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 9 · no fix planned: Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 9 · updated 2026-10-21 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-96889.json)
- **RHSA-2026:86331** · Red Hat · fixed in: Red Hat Enterprise Linux AppStream (v. 10) · released 2026-10-21 · [advisory](https://access.redhat.com/errata/RHSA-2026:86331)
- **RHSA-2026:86841** · Red Hat · fixed in: Red Hat Enterprise Linux AppStream (v. 10) · released 2026-10-21 · [advisory](https://access.redhat.com/errata/RHSA-2026:86841)
- **RHSA-2026:86842** · Red Hat · fixed in: Red Hat Enterprise Linux AppStream (v. 8) · released 2026-10-21 · [advisory](https://access.redhat.com/errata/RHSA-2026:86842)
