---
id: CVE-2026-97020
title: >-
  The PO/MO Editor plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'podata' parameter in all versions up to, and including,
  1.4.2 due to insufficient input sanitization and output escaping
summary: >-
  The PO/MO Editor plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'podata' parameter in all versions up to, and including,
  1.4.2 due to insufficient input sanitization and output escaping. This makes
  it possible …
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: dougwollison
product: PO/MO Editor
affected:
  - po_mo_editor <= 1.4.2
published: '2026-10-14'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T16:18:24.697'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-97020'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/pomo-editor/trunk/includes/class-pomoeditor-manager.php#L110
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/pomo-editor/trunk/includes/class-pomoeditor-manager.php#L115
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/pomo-editor/trunk/includes/class-pomoeditor-manager.php#L177
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/pomo-editor/trunk/includes/class-pomoeditor-manager.php#L41
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/pomo-editor/trunk/includes/class-pomoeditor-system.php#L78
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/a06e1a22-f660-401b-bfbf-0064a9220c26?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00255
epssPercentile: 0.16997
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-14T16:11:36.117830Z'
ingestedAt: '2026-10-14T05:14:27.659Z'
---

## Overview

The PO/MO Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'podata' parameter in all versions up to, and including, 1.4.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected payload is loaded as a replacement .po/.mo translation file via the plugin's own load_textdomain_mofile filter, causing WordPress to serve the attacker-written translation in place of the original core strings.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
