---
id: CVE-2026-97227
title: >-
  The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.4.8
  does not perform capability or ownership checks on several of its AJAX
  actions, relying on a nonce alone, allowing users an administrator has granted
  access to it…
summary: >-
  The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.4.8
  does not perform capability or ownership checks on several of its AJAX
  actions, relying on a nonce alone, allowing users an administrator has granted
  access to it…
severity: medium
cvss: 5.9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N'
cwe:
  - CWE-862
product: 'NextScripts: Social Networks Auto-Poster'
affected:
  - nextscripts_social_networks_auto-poster < 4.4.8
published: '2026-09-27'
updated: '2026-09-28'
sourceUpdated: '2026-09-28T15:17:39.543'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-97227'
references:
  - url: 'https://wpscan.com/vulnerability/df187bfb-47f1-4259-b955-3c676f3d8cc1/'
    label: contact@wpscan.com
tags:
  - nvd
  - cve.org
epss: 0.00183
epssPercentile: 0.07835
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-28T00:36:56.239323Z'
ingestedAt: '2026-09-27T06:43:46.835Z'
---

## Overview

The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.4.8 does not perform capability or ownership checks on several of its AJAX actions, relying on a nonce alone, allowing users an administrator has granted access to its posting features to export the site's configured social account credentials, delete arbitrary posts and reset the NextScripts: Social Networks Auto-Poster WordPress plugin before 4.4.8's configuration.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
