---
id: CVE-2026-97229
title: >-
  GitLab has remediated an issue in GitLab CE/EE affecting all versions from
  19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under
  certain conditions, could have allowed an unauthenticated user to execute
  arbitrary cod…
summary: >-
  GitLab has remediated an issue in GitLab CE/EE affecting all versions from
  19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under
  certain conditions, could have allowed an unauthenticated user to execute
  arbitrary cod…
severity: critical
cvss: 10
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H'
cwe:
  - CWE-190
vendor: gitlab
product: gitlab
affected:
  - 'gitlab >= 19.2.0, < 19.2.8'
  - 'gitlab >= 19.3.0, < 19.3.5'
  - 'gitlab >= 19.4.0, < 19.4.2'
patched:
  - gitlab 19.4.2
published: '2026-10-13'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T13:55:26.987'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-97229'
references:
  - url: >-
      https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/
    label: cve@gitlab.com
  - url: 'https://gitlab.com/gitlab-org/gitlab/-/work_items/630686'
    label: cve@gitlab.com
  - url: 'https://hackerone.com/reports/4055749'
    label: cve@gitlab.com
  - url: 'https://hackerone.com/reports/4058589'
    label: cve@gitlab.com
tags:
  - nvd
  - exploit-available
  - cve.org
epss: 0.18427
epssPercentile: 0.9722
exploits:
  github: 3
  githubRepos:
    - 'https://github.com/gandli/cve-2026-97229-lab'
    - >-
      https://github.com/AmpedWasTaken/CVE-2026-97229-GitLab-CI-CD-Regex-Compiler-RCE
    - 'https://github.com/Noshadi-sec/CVE-2026-97229'
  checkedAt: '2026-10-27T19:24:50.520Z'
exploitAvailable: true
ingestedAt: '2026-10-13T03:13:19.000Z'
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-14T03:59:10.957307Z'
---

## Overview

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.

## Affected

- `gitlab >= 19.2.0, < 19.2.8`
- `gitlab >= 19.3.0, < 19.3.5`
- `gitlab >= 19.4.0, < 19.4.2`

## Remediation

Upgrade past the affected range:

- `gitlab 19.4.2`
