---
id: CVE-2026-97397
title: >-
  Remove Google Fonts <= 1.7 - Unauthenticated Stored Cross-Site Scripting via
  Comment Field via Regex-Mangled Output Buffer
summary: >-
  The Remove Google Fonts – Disable, Block, or Replace with Bunny Fonts for GDPR
  Compliance plugin for WordPress is vulnerable to Stored Cross-Site Scripting
  via Comment Field via Regex-Mangled Output Buffer in all versions up to, and
  incl…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: easywpstuff
product: >-
  Remove Google Fonts – Disable, Block, or Replace with Bunny Fonts for GDPR
  Compliance
affected:
  - >-
    remove_google_fonts_disable_block_or_replace_with_bunny_fonts_for_gdpr_compliance
    <= 1.7
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-11-04T14:40:25.987913Z'
published: '2026-11-04'
updated: '2026-11-04'
sourceUpdated: '2026-11-04T15:18:54.742Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-97397'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/79ff2a5d-ee75-4dc2-85a0-6eb1a032678c?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/use-bunnyfont-host-google-fonts/tags/1.7/bunnyfont.php#L253
  - url: >-
      https://plugins.trac.wordpress.org/browser/use-bunnyfont-host-google-fonts/tags/1.7/bunnyfont.php#L162
  - url: >-
      https://plugins.trac.wordpress.org/browser/use-bunnyfont-host-google-fonts/tags/1.7/bunnyfont.php#L248
tags:
  - cve.org
ingestedAt: '2026-11-05T21:36:00.408Z'
epss: 0.00296
epssPercentile: 0.22396
---

## Overview

The Remove Google Fonts – Disable, Block, or Replace with Bunny Fonts for GDPR Compliance plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Field via Regex-Mangled Output Buffer in all versions up to, and including, 1.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires the plugin's Remove mode to be active and the malicious comment to be published, either through auto-approval for known commenters or manual moderator approval.

## Affected

- `remove_google_fonts_disable_block_or_replace_with_bunny_fonts_for_gdpr_compliance <= 1.7`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
