---
id: CVE-2026-97642
title: >-
  Wp Parsidate <= 6.4 - Authenticated (Contributor+) Stored Cross-Site Scripting
  via 'theme' Block Attribute
summary: >-
  The Wp Parsidate plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the calendar Gutenberg block's 'theme' attribute in versions up
  to, and including, 6.4. This is due to insufficient input sanitization and
  output esca…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: man4toman
product: Parsi Date | بسته فارسی ساز وردپرس و ووکامرس پارسی دیت
affected:
  - parsi_date <= 6.4
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-06T14:59:32.777593Z'
published: '2026-11-06'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T15:02:14.239Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-97642'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/a88daa7b-dd50-4037-b354-bdabdac7bfbd?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-parsidate/tags/6.4/inc/Core/Calendar.php#L146
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-parsidate/tags/6.4/inc/Block/CalendarBlock.php#L40
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-parsidate/tags/6.4/inc/Core/Calendar.php#L325
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3775046%40wp-parsidate&new=3775046%40wp-parsidate
tags:
  - cve.org
epss: 0.00331
epssPercentile: 0.26456
ingestedAt: '2026-11-06T09:48:47.392Z'
---

## Overview

The Wp Parsidate plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the calendar Gutenberg block's 'theme' attribute in versions up to, and including, 6.4. This is due to insufficient input sanitization and output escaping on the block attribute value which is concatenated directly into an HTML class attribute in the printCalendar() function without esc_attr(). This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Affected

- `parsi_date <= 6.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
