---
id: CVE-2026-97645
title: >-
  Gravity Forms <= 3.1.2 - Unauthenticated Stored Cross-Site Scripting via List
  Field
summary: >-
  The Gravity Forms plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via List Field in all versions up to, and including, 3.1.2 due to
  insufficient input sanitization and output escaping. This makes it possible
  for unauthe…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: Gravity Forms
product: Gravity Forms
affected:
  - gravity_forms <= 3.1.2
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-30T15:47:44.482314Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T15:57:26.069Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-97645'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/9889e718-381b-4d11-a234-0278037c61c4?source=cve
  - url: 'https://docs.gravityforms.com/'
tags:
  - cve.org
epss: 0.0019
epssPercentile: 0.0878
ingestedAt: '2026-11-05T16:24:31.044Z'
---

## Overview

The Gravity Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via List Field in all versions up to, and including, 3.1.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires the administrator to click the injected link in the entry detail view and confirm a dialog, which triggers the admin JavaScript bundle's delegated data-dialog-callback handler to invoke the attacker-supplied function reference.

## Affected

- `gravity_forms <= 3.1.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
