---
id: CVE-2026-9812
title: >-
  Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7,
  10.11.x <= 10.11.22 fail to validate that a property field belongs to the
  specified run before updating its value which allows an authenticated user
  with run prope…
summary: >-
  Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7,
  10.11.x <= 10.11.22 fail to validate that a property field belongs to the
  specified run before updating its value which allows an authenticated user
  with run prope…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-639
vendor: mattermost
product: mattermost_server
affected:
  - 'mattermost_server >= 10.11.0, < 10.11.23'
  - 'mattermost_server >= 11.7.0, < 11.7.8'
  - 'mattermost_server >= 11.8.0, < 11.8.5'
  - 'mattermost_server >= 11.9.0, < 11.9.1'
patched:
  - mattermost_server 11.9.1
published: '2026-09-14'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T17:55:57.020'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-9812'
references:
  - url: 'https://mattermost.com/security-updates'
    label: responsibledisclosure@mattermost.com
tags:
  - nvd
  - cve.org
epss: 0.00368
epssPercentile: 0.30483
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-09-14T11:03:43.239891Z'
ingestedAt: '2026-09-14T15:23:07.462Z'
---

## Overview

Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7, 10.11.x <= 10.11.22 fail to validate that a property field belongs to the specified run before updating its value which allows an authenticated user with run property-management access to crash the Playbooks plugin via a REST request referencing a property field that belongs to a different run. Mattermost Advisory ID: MMSA-2026-00684

## Affected

- `mattermost_server >= 10.11.0, < 10.11.23`
- `mattermost_server >= 11.7.0, < 11.7.8`
- `mattermost_server >= 11.8.0, < 11.8.5`
- `mattermost_server >= 11.9.0, < 11.9.1`

## Remediation

Upgrade past the affected range:

- `mattermost_server 11.9.1`
