GHSA-c33x-vcv4-vg3gLow▾ SunlitCedar: JSON template is in scope missing slot-id validation allows link panic and decision divergence
▾ Sunlit zone — Low / medium · no exploitation signal
impact 13.8 · likelihood 0 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Cedar users must be using all of the following features to be affected by this advisory: JSON format policies, policy templates, and the is in scope condition. This advisory only affects JSON-formatted Cedar policy templates containing is in scope conditions that are malformed according to the Cedar syntax. It does not affect syntactically well-formed policies.
Users of Cedar who author policies in the JSON format were able to write Cedar policies using the is in condition with an incorrect slot identifier in the principal and resource scope constraints (e.g., ?principal in the resource scope constraint) even though this is not allowed when parsing policies from the Cedar policy syntax. Internally, the slot identifiers were silently corrected (e.g. ?resource is placed in the resource scope constraint).
If the policy contains exactly one slot in either the principal or resource position, then any attempt to create a linked policy from the template results in an error: the internal representation of the template does not contain the slot identifier as written in the malformed JSON policy (it has been corrected silently), so attempting to fill that slot is an error. If instead the template is linked using slot identifier expected internally (i.e., not what is written in the JSON template), the linking will initially succeed, but a subsequent invariant violation will cause a panic.
When the template contains slots in both the principal and resource position, then both slots will be present in the internal representation: linking succeeds, but with each slot bound to the value intended for the other (the silent correction). The linked policy is then semantically different from the malformed policy the user intended, and any subsequent authorization decision made against that policy may lead to accesses being unintentionally allowed or denied.
Concretely, consider the following JSON format policy template intended to deny users in a particular project from accessing documents with a particular classification.
{
"effect": "forbid",
"principal": {
"op": "is",
"entity_type": "User",
"in": { "slot": "?resource" }
},
"action": { "op": "All" },
"resource": {
"op": "is",
"entity_type": "Doc",
"in": { "slot": "?principal" }
},
"conditions": []
}
Linked with ?principal = Classification::"topsecret" and ?resource = Project::"alpha", the author expects to create the policy:
forbid(principal is User in Project::"alpha", action, resource is Doc in Classification::"topsecret");
But because Cedar internally links slots by scope position (not by name), the actual policy evaluated by the engine is:
forbid(principal is User in Classification::"topsecret", action, resource is Doc in Project::"alpha");
If a user is in Project::"alpha" but not Classification::"topsecret", the forbid policy does not apply, and access is unintentionally allowed.
This advisory is patched in version 4.11.1 and 3.4.3, both available on Crates.io and NPM.
If you cannot update to a patched version, you can determine if you are affected by checking your JSON format policy templates for the following two patterns.
"principal": {
"op": "is",
"entity_type": "User",
"in": { "slot": "?resource" }
}
and
"resource": {
"op": "is",
"entity_type": "Doc",
"in": { "slot": "?principal" }
}
cedar-policy >= 4.0.0, < 4.11.1cedar-policy >= 3.0.0, < 3.4.3@cedar-policy/cedar-wasm >= 4.0.1, < 4.11.1@cedar-policy/cedar-wasm >= 3.2.0, < 3.4.3Upgrade to a patched release:
cedar-policy 4.11.1cedar-policy 3.4.3@cedar-policy/cedar-wasm 4.11.1@cedar-policy/cedar-wasm 3.4.3Connected by shared product, vendor, weakness, or advisory.
CVE-2021-45105Medium· 5.9Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3 and 2.3.1) did not protect from uncontrolled recursion from self-referential lookups
CVE-2020-3478High· 8.1A vulnerability in the REST API of Cisco Enterprise NFV Infrastructure Software (NFVIS) could allow an authenticated, remote attacker to overwrite certain files that should be restricted on an affected device
CVE-2020-3577High· 7.4A vulnerability in the ingress packet processing path of Cisco Firepower Threat Defense (FTD) Software for interfaces that are configured either as Inline Pair or in Passive mode could allow an unauthenticated, adjacent attacker to cause…
CVE-2020-3317High· 7.5A vulnerability in the ssl_inspection component of Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to crash Snort instances
CVE-2020-3191High· 8.6A vulnerability in DNS over IPv6 packet processing for Cisco Adaptive Security Appliance (ASA) Software and Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause the device to unexpectedly reloa…
CVE-2020-3166Medium· 6.7A vulnerability in the CLI of Cisco FXOS Software could allow an authenticated, local attacker to read or write arbitrary files on the underlying operating system (OS)