---
id: GHSA-jm5p-837g-rv8g
title: 'Wagtail: Improper restriction handling on Page translation API endpoint'
summary: 'Wagtail: Improper restriction handling on Page translation API endpoint'
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
vendor: wagtail
product: wagtail
ecosystem: pip
affected:
  - wagtail < 7.0.9
  - 'wagtail >= 7.1rc1, < 7.3.4'
  - 'wagtail >= 7.4rc1, < 7.4.3'
  - 'wagtail >= 8.0rc1, < 8.0rc2'
patched:
  - wagtail 7.0.9
  - wagtail 7.3.4
  - wagtail 7.4.3
  - wagtail 8.0rc2
published: '2026-08-20'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T15:00:05.236346348Z'
source: OSV
sourceUrl: 'https://osv.dev/vulnerability/GHSA-jm5p-837g-rv8g'
references:
  - url: 'https://github.com/wagtail/wagtail/security/advisories/GHSA-jm5p-837g-rv8g'
  - url: 'https://github.com/wagtail/wagtail'
  - url: 'https://github.com/wagtail/wagtail/releases/tag/v7.0.9'
  - url: 'https://github.com/wagtail/wagtail/releases/tag/v7.3.4'
  - url: 'https://github.com/wagtail/wagtail/releases/tag/v7.4.3'
  - url: 'https://github.com/wagtail/wagtail/releases/tag/v8.0rc2'
  - url: 'https://github.com/advisories/GHSA-jm5p-837g-rv8g'
tags:
  - osv
  - pip
  - ghsa
cwe:
  - CWE-280
ingestedAt: '2026-08-20T18:59:53.199Z'
---

## Overview

### Impact
A CMS user with the "submit translations" permission, could use the Admin API's "copy for translation" endpoint to copy an existing page that they do not have edit access to, allowing them to view its contents.

### Patches
Patched versions have been released as Wagtail 7.0.9, 7.3.4, 7.4.3 and 8.0rc2.

### Workarounds
N/A

### Acknowledgements
Many thanks to tinyb0y for reporting this issue.

### For more information
If you have any questions or comments about this advisory:

* Visit Wagtail's [support channels](https://docs.wagtail.org/en/stable/support.html)
* Email us at [security@wagtail.org](mailto:security@wagtail.org) (view our [security policy](https://github.com/wagtail/wagtail/security/policy) for more information).

## Affected packages

- `wagtail < 7.0.9`
- `wagtail >= 7.1rc1, < 7.3.4`
- `wagtail >= 7.4rc1, < 7.4.3`
- `wagtail >= 8.0rc1, < 8.0rc2`

## Remediation

Upgrade to a patched release:

- `wagtail 7.0.9`
- `wagtail 7.3.4`
- `wagtail 7.4.3`
- `wagtail 8.0rc2`
