VulnSea

thephpleague has 12 CVEs on record. Disclosure cadence is accelerating: 12 in the last 90 days against 0 in the 90 before. The busiest recent month was September 2026 with 10. The median CVSS is 7.5 (high). None have a confirmed exploitation report. The most common weakness class is CWE-407 (7). Most affected products: commonmark (11), flysystem (1).

CVEs per month

Last 12 months, by publish date

111201020304050607080910
Exploited share
0% vs 1% corpus
Median CVSS
7.5
Publish → KEV
—
Last 90 days
12 prev 0

Products

  • commonmark 11
  • flysystem 1
12
Total CVEs
0
Critical
0
CISA KEV
0
Exploited

thephpleague vulnerabilities

CVEs affecting thephpleague, newest first. Open any entry for full detail, references, and exploit status.

12 CVEsRSS

CVE-2026-105830High· 7.5PoC
2w ago

league/commonmark from 2.0.0 before 2.10.2 contains a quadratic-time denial of service vulnerability in the GitHub Flavored Markdown Table extension's TableStartParser::tryStart() block-start scan

league/commonmark from 2.0.0 before 2.10.2 contains a quadratic-time denial of service vulnerability in the GitHub Flavored Markdown Table extension's TableStartParser::tryStart() block-start scan. Unauthenticated attackers can submit a …

▾ Midnightthephpleague · commonmarkEPSS 0.37%via NVD
CVE-2026-105829Medium· 6.1PoC
2w ago

League CommonMark from 1.3.0 before 2.10.2 contains a cross-site scripting vulnerability that allows users posting Markdown to bypass the DisallowedRawHtml extension by ending raw HTML with a bare disallowed tag name

League CommonMark from 1.3.0 before 2.10.2 contains a cross-site scripting vulnerability that allows users posting Markdown to bypass the DisallowedRawHtml extension by ending raw HTML with a bare disallowed tag name. Attackers can place…

▾ Twilightthephpleague · commonmarkEPSS 0.25%via NVD
CVE-2026-102601Low· 3.5PoC
4w ago

Flysystem is an open source file storage library for PHP

Flysystem is an open source file storage library for PHP. Prior to 3.35.3, the default WhitespacePathNormalizer in src/WhitespacePathNormalizer.php used by Filesystem across adapters calls preg_match with the u modifier and treats both f…

▾ Twilightthephpleague · flysystemEPSS 0.34%via NVD
CVE-2024-58382High· 7.5
1mo ago

league/commonmark versions before 2.6.0 contain polynomial time complexity vulnerabilities in Markdown parsing that allow attackers to cause denial of service

league/commonmark versions before 2.6.0 contain polynomial time complexity vulnerabilities in Markdown parsing that allow attackers to cause denial of service. Attackers can submit carefully crafted Markdown inputs designed to trigger wo…

▾ Twilightthephpleague · commonmarkEPSS 0.49%via NVD
CVE-2026-86435High· 7.5
1mo ago

commonmark versions from 1.5.0 before 2.8.4 contain a denial of service vulnerability in the Footnote extension that fails to deduplicate footnote definitions

commonmark versions from 1.5.0 before 2.8.4 contain a denial of service vulnerability in the Footnote extension that fails to deduplicate footnote definitions. Attackers can craft documents with duplicate footnote definitions and referen…

▾ Twilightthephpleague · commonmarkEPSS 0.49%via NVD
CVE-2026-86434High· 7.5
1mo ago

league/commonmark versions >= 2.0.0 and < 2.8.4 (patched in 2.9.0) contain a denial of service vulnerability in UniqueSlugNormalizer::normalize(), which restarts its numeric-suffix search from 1 on every slug collision, resulting in O(K^…

league/commonmark versions >= 2.0.0 and < 2.8.4 (patched in 2.9.0) contain a denial of service vulnerability in UniqueSlugNormalizer::normalize(), which restarts its numeric-suffix search from 1 on every slug collision, resulting in O(K^…

▾ Twilightthephpleague · commonmarkEPSS 0.51%via NVD
CVE-2026-86432Medium· 5.3
1mo ago

commonmark versions from 2.0.0 before 2.8.4 contain a denial of service vulnerability in XmlRenderer that emits depth-proportional indentation for every XML tag

commonmark versions from 2.0.0 before 2.8.4 contain a denial of service vulnerability in XmlRenderer that emits depth-proportional indentation for every XML tag. Attackers can provide deeply nested Markdown or AST structures to cause qua…

▾ Sunlitthephpleague · commonmarkEPSS 0.42%via NVD
CVE-2026-86430High· 7.5
1mo ago

league/commonmark versions before 2.9.1 contain multiple denial of service vulnerabilities in fenced code block detection, reference link label lookup, and emphasis delimiter processing that perform super-linear work on crafted input

league/commonmark versions before 2.9.1 contain multiple denial of service vulnerabilities in fenced code block detection, reference link label lookup, and emphasis delimiter processing that perform super-linear work on crafted input. At…

▾ Twilightthephpleague · commonmarkEPSS 0.49%via NVD
CVE-2026-86429High· 7.5
1mo ago

The league/commonmark (thephpleague/commonmark) library in versions >= 1.5.0 and < 2.9.1 contains quadratic parsing complexity in its SmartPunctExtension and AttributesExtension

The league/commonmark (thephpleague/commonmark) library in versions >= 1.5.0 and < 2.9.1 contains quadratic parsing complexity in its SmartPunctExtension and AttributesExtension. When either extension is explicitly registered on the Envi…

▾ Twilightthephpleague · commonmarkEPSS 0.52%via NVD
CVE-2026-86433High· 7.5
1mo ago

commonmark versions from 1.5.0 before 2.8.4 contain a denial of service vulnerability in the Attributes extension where AttributesListener::findTargetAndDirection() performs quadratic-time sibling list scanning

commonmark versions from 1.5.0 before 2.8.4 contain a denial of service vulnerability in the Attributes extension where AttributesListener::findTargetAndDirection() performs quadratic-time sibling list scanning. Unauthenticated attackers…

▾ Twilightthephpleague · commonmarkEPSS 0.51%via NVD
CVE-2026-86431High· 7.2
1mo ago

league/commonmark (thephpleague/commonmark) versions >= 2.7.0 and < 2.9.1 contain a cross-site scripting vulnerability in the AttributesExtension

league/commonmark (thephpleague/commonmark) versions >= 2.7.0 and < 2.9.1 contain a cross-site scripting vulnerability in the AttributesExtension. Prefixing an attribute name with a single U+000C form feed byte (e.g. {\x0Conclick="alert(…

▾ Twilightthephpleague · commonmarkEPSS 0.39%via NVD
CVE-2026-86428High· 7.5
1mo ago

commonmark versions from 1.5.0 before 2.10.0 contain a denial of service vulnerability in the AttributesExtension when processing distinctly-named attributes

commonmark versions from 1.5.0 before 2.10.0 contain a denial of service vulnerability in the AttributesExtension when processing distinctly-named attributes. Attackers can submit Markdown with numerous distinct attribute names to cause …

▾ Twilightthephpleague · commonmarkEPSS 0.49%via NVD
thephpleague vulnerabilities (CVEs) · VulnSea