CVE-2026-109869High· 7.5▾ Twilightundici is an HTTP client library for Node.js. In versions 6.23.0 through 6.29.0, 7.18.0 through 7.30.0, and 8.0.0 through 8.12.1, its fetch() implementation crashes the Node.js process when a malicious server returns a response with more…
▾ Twilight zone — High severity, or a signal on a lesser flaw
impact 41.3 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Stakeholder-Specific Vulnerability Categorization from CISA's ADP record at CVE.org: whether exploitation is observed, whether an attack can be automated, and how much of the system is at stake.
Exploit-prediction probability, daily snapshots since Oct 16.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
0.3%
0.3% → 0.3%
undici is an HTTP client library for Node.js. In versions 6.23.0 through 6.29.0, 7.18.0 through 7.30.0, and 8.0.0 through 8.12.1, its fetch() implementation crashes the Node.js process when a malicious server returns a response with more than five content codings and closes the connection before sending the body. undici rejects such responses because of a content-encoding limit, but it created the internal response stream before that check and returned without attaching an error listener or aborting the request, so the early close surfaces a content-length mismatch on the orphaned stream, which Node.js treats as an unhandled error and terminates the process. A remote, unauthenticated server can trigger this with a single response, even when the application correctly catches the fetch() rejection, resulting in a denial of service. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. There is no workaround.
Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
Affected packages:
undici >= 6.23.0, < 6.29.1undici >= 7.18.0, < 7.30.1undici >= 8.0.0, < 8.12.2Patched in:
undici 6.29.1undici 7.30.1undici 8.12.2Connected by shared product, vendor, weakness, or advisory.
CVE-2026-87018High· 7.5undici is an HTTP client library for Node.js
CVE-2026-87029Medium· 5.9undici is an HTTP client library for Node.js
CVE-2026-109932Medium· 5.9undici is an HTTP client library for Node.js
CVE-2026-109924Medium· 5.9undici is an HTTP client library for Node.js
CVE-2026-109841Medium· 5.9undici is an HTTP client library for Node.js
CVE-2026-109829High· 7.4undici is an HTTP client library for Node.js