CVE-2026-109932Medium· 5.9▾ Sunlitundici is an HTTP client library for Node.js. In versions 5.15.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its WebSocket client, including the bundled WebSocket exposed by Node.js, can be driven to exhaust process m…
▾ Sunlit zone — Low / medium · no exploitation signal
impact 32.5 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Stakeholder-Specific Vulnerability Categorization from CISA's ADP record at CVE.org: whether exploitation is observed, whether an attack can be automated, and how much of the system is at stake.
Exploit-prediction probability, daily snapshots since Oct 16.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
0.3%
0.3% → 0.3%
undici is an HTTP client library for Node.js. In versions 5.15.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its WebSocket client, including the bundled WebSocket exposed by Node.js, can be driven to exhaust process memory by a malicious or compromised WebSocket server. For every PING frame received, the client automatically writes a PONG response and ignores the backpressure signal from the socket write, so a server that streams small PING frames while never reading the client's PONGs makes the outbound write queue and heap grow without bound until the Node.js process runs out of memory and terminates. The attack is remote and unauthenticated, needs only a normal WebSocket connection, and is asymmetric, since small inbound PINGs produce a much larger retained outbound queue, with availability the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which pause WebSocket frame parsing when the automatic PONG response hits socket backpressure and resume on drain, bounding the outbound queue, and users should upgrade to one of those versions or later. There is no workaround.
Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
Affected packages:
undici >= 5.15.0, < 6.29.1undici >= 7.0.0, < 7.30.1undici >= 8.0.0, < 8.12.2Patched in:
undici 6.29.1undici 7.30.1undici 8.12.2Connected by shared product, vendor, weakness, or advisory.
CVE-2026-109924Medium· 5.9undici is an HTTP client library for Node.js
CVE-2026-87018High· 7.5undici is an HTTP client library for Node.js
CVE-2026-87029Medium· 5.9undici is an HTTP client library for Node.js
CVE-2026-109841Medium· 5.9undici is an HTTP client library for Node.js
CVE-2026-109869High· 7.5undici is an HTTP client library for Node.js
CVE-2026-109829High· 7.4undici is an HTTP client library for Node.js