CVE-2026-62674Critical· 9.0▾ MidnightOmnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents. Prior to 0.3.0, PUT /sessions/{session_id}/agent checks LEVEL_EDIT permission for a session but does not reject a bound shared or template ag…
▾ Midnight zone — Critical, or high with PoC / in-the-wild
impact 49.5 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Sep 2.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
0.3%
0.3% → 0.5%
Last analysed / modified upstream
Omnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents. Prior to 0.3.0, PUT /sessions/{session_id}/agent checks LEVEL_EDIT permission for a session but does not reject a bound shared or template agent whose agent.session_id is None. An authenticated user with edit access to a session can replace that shared agent bundle through omnigent/server/routes/sessions.py, add a stdio MCP server, and cause later sessions that use the shared agent to launch an attacker-controlled command through omnigent/tools/mcp.py. The command executes with the Omnigent runner process permissions and can expose files, credentials, workspace data, internal services, and runner availability. This issue is fixed in version 0.3.0.
Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
Affected packages:
omnigent < 0.3.0Patched in:
omnigent 0.3.0Connected by shared product, vendor, weakness, or advisory.
CVE-2026-62675High· 8.8Omnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents
CVE-2026-62677High· 8.8Omnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents
CVE-2026-62676High· 7.1Omnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents
CVE-2026-112015High· 7.5Omnigent 0.3.0 before 0.14.0 Path Traversal via Sub-Agent os_env.cwd
CVE-2024-3098Critical· 9.8llama-index-core Prompt Injection vulnerability leading to Arbitrary Code Execution
CVE-2024-3955Critical· 9.8CraftBeerPi 4 allows arbitrary code execution