CVE-2026-62675High· 8.8▾ TwilightOmnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents. Prior to 0.3.0, multipart POST /v1/sessions accepts an authenticated user's agent bundle and omnigent/server/bundles.py validate_agent_bundle…
▾ Twilight zone — High severity, or a signal on a lesser flaw
impact 48.4 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Sep 2.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
0.4%
0.4% → 0.7%
Last analysed / modified upstream
Omnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents. Prior to 0.3.0, multipart POST /v1/sessions accepts an authenticated user's agent bundle and omnigent/server/bundles.py validate_agent_bundle does not reject a tools..callable dotted Python path. omnigent/runner/tool_dispatch.py _resolve_spec_callable imports the specified module and _execute_spec_callable_tool invokes the resolved function, allowing a bundle to select subprocess.check_output and execute a local command with the runner process permissions. This can expose runner files, environment variables, credentials, workspace data, internal services, and availability without administrator access. This issue is fixed in version 0.3.0.
Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
Affected packages:
omnigent < 0.3.0Patched in:
omnigent 0.3.0Connected by shared product, vendor, weakness, or advisory.
CVE-2026-62674Critical· 9.0Omnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents
CVE-2026-62677High· 8.8Omnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents
CVE-2026-62676High· 7.1Omnigent is an open-source AI agent framework and meta-harness for orchestrating coding agents
CVE-2026-112015High· 7.5Omnigent 0.3.0 before 0.14.0 Path Traversal via Sub-Agent os_env.cwd
CVE-2024-3098Critical· 9.8llama-index-core Prompt Injection vulnerability leading to Arbitrary Code Execution
CVE-2024-3955Critical· 9.8CraftBeerPi 4 allows arbitrary code execution