CVE-2026-75975High· 7.5▾ Twilightfast-uri is a URI parser for Node.js. Its custom parser for bracketed IPv6 literals does not validate the complete IPv6 grammar, so invalid trailing text in an authority can be silently discarded and a malformed attacker-controlled host …
▾ Twilight zone — High severity, or a signal on a lesser flaw
impact 41.3 · likelihood 0 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Sep 2.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
0.2%
0.2% → 0.4%
Last analysed / modified upstream
fast-uri is a URI parser for Node.js. Its custom parser for bracketed IPv6 literals does not validate the complete IPv6 grammar, so invalid trailing text in an authority can be silently discarded and a malformed attacker-controlled host is turned into a different valid IPv6 destination. For example, a bracketed literal with invalid trailing characters is normalized to the unspecified address, which a Node HTTP client then connects to a local service over loopback, and other malformed literals collapse to private-range addresses. No error is set on the parsed result, so an application checking the error field cannot detect the rewrite. An application that normalizes untrusted URLs before outbound requests, redirects, proxy routing, or address-policy enforcement can be redirected to a local or private IPv6 target, giving a server-side request forgery and address-policy bypass primitive. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which validate bracketed IP literals against the full grammar and mark malformed literals as authority errors. Users should upgrade to a patched version.
fast-uri >= 2.3.1, < 2.4.5fast-uri >= 3.0.0, < 3.1.6fast-uri >= 4.0.0, < 4.1.3Upgrade past the affected range:
fast-uri 4.1.3Affected packages:
fast-uri >= 2.3.1, < 2.4.5fast-uri >= 3.0.0, < 3.1.6fast-uri >= 4.0.0, < 4.1.3Patched in:
fast-uri 2.4.5fast-uri 3.1.6fast-uri 4.1.3Source: https://github.com/advisories/GHSA-f65p-4m7j-42xc
Connected by shared product, vendor, weakness, or advisory.
CVE-2026-75899High· 7.5fast-uri is a URI parser for Node.js
CVE-2026-84292High· 7.5fast-uri serializes the port component of a URI without validating it
CVE-2026-76172High· 7.5fast-uri is a URI parser for Node.js
CVE-2026-75931High· 7.5fast-uri is a URI parser for Node.js
CVE-2026-110180Medium· 4.8fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization
CVE-2026-110095Low· 3.7fast-uri vulnerable to improper path equivalence in relative reference normalization