CVE-2026-76172High· 7.5▾ Twilightfast-uri is a URI parser for Node.js. During parsing it runs a legacy decoding pass over the scheme component and never re-escapes the result, and serialization writes the scheme back out verbatim, unlike the host component which is re-e…
▾ Twilight zone — High severity, or a signal on a lesser flaw
impact 41.3 · likelihood 0 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Sep 2.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
0.2%
0.2% → 0.4%
Last analysed / modified upstream
fast-uri is a URI parser for Node.js. During parsing it runs a legacy decoding pass over the scheme component and never re-escapes the result, and serialization writes the scheme back out verbatim, unlike the host component which is re-escaped. As a result an input whose scheme carries percent-encoded slashes parses as a scheme with no authority, so the parsed host and error are both undefined, yet resolving or normalizing that same input emits a network-path reference whose authority is attacker-chosen and re-parses to that host. An application that allowlists on the parsed host, or treats a reference with no authority as safe to resolve against its base, gets the opposite of what it checked, giving an off-site redirect, server-side request forgery, or address-policy bypass. The legacy decoder also expands non-standard escape forms, widening the issue past upstream filters, and control characters in the scheme can reach the output as raw carriage return and line feed. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which reject a scheme that is not valid after decoding. Users should upgrade to a patched version.
fast-uri >= 2.3.1, < 2.4.5fast-uri >= 3.0.0, < 3.1.6fast-uri >= 4.0.0, < 4.1.3Upgrade past the affected range:
fast-uri 4.1.3Affected packages:
fast-uri >= 2.3.1, < 2.4.5fast-uri >= 3.0.0, < 3.1.6fast-uri >= 4.0.0, < 4.1.3Patched in:
fast-uri 2.4.5fast-uri 3.1.6fast-uri 4.1.3Source: https://github.com/advisories/GHSA-jqff-g426-hqxp
Connected by shared product, vendor, weakness, or advisory.
CVE-2026-84292High· 7.5fast-uri serializes the port component of a URI without validating it
CVE-2026-75899High· 7.5fast-uri is a URI parser for Node.js
CVE-2026-75975High· 7.5fast-uri is a URI parser for Node.js
CVE-2026-75931High· 7.5fast-uri is a URI parser for Node.js
CVE-2026-110095Low· 3.7fast-uri vulnerable to improper path equivalence in relative reference normalization
CVE-2026-110180Medium· 4.8fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization