CVE-2026-101288High· 8.8▾ TwilightIBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to execute arbitrary code due to improper neutralization of special elements used in code.
▾ Twilight zone — High severity, or a signal on a lesser flaw
impact 48.4 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Stakeholder-Specific Vulnerability Categorization from CISA's ADP record at CVE.org: whether exploitation is observed, whether an attack can be automated, and how much of the system is at stake. The CVSS score shown above comes from the assigning CNA record, not NVD.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via CVEORG
Last analysed / modified upstream
0.7%
IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to execute arbitrary code due to improper neutralization of special elements used in code.
langflow_oss >= 1.0.0 <= 1.12.3IBM strongly recommends addressing the vulnerability now by upgrading Langflow OSS to version 1.12.4. https://pypi.org/project/langflow/1.12.4/
For Langflow OSS versions 1.0.0 - 1.12.3, follow the Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the Langflow OSS installation instructions https://docs.langflow.org/get-started-installation to install version 1.12.4 and test your flows.
Connected by shared product, vendor, weakness, or advisory.
CVE-2026-104328High· 8.8Langflow OSS is affected by multiple vulnerabilities
CVE-2026-104339Critical· 9.8Langflow OSS is affected by multiple vulnerabilities
CVE-2026-104324High· 8.8Langflow OSS is affected by multiple vulnerabilities
CVE-2026-107329Critical· 9.9Langflow OSS is affected by multiple vulnerabilities
CVE-2026-110186Critical· 9.8Langflow OSS is affected by multiple vulnerabilities
CVE-2026-104317High· 8.1Langflow OSS is affected by multiple vulnerabilities