CVE-2026-110186Critical· 9.8▾ AbyssalPoC availableIBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker to execute arbitrary code due to improper control of code generation.
▾ Abyssal zone — Critical with a public exploit or in-the-wild use
impact 53.9 · likelihood 0.1 · exploitation 12
A public proof-of-concept already exists for this vulnerability — see Exploit availability below.
Public exploit / PoC code seen in 1 source. Availability, not in-the-wild use.
Stakeholder-Specific Vulnerability Categorization from CISA's ADP record at CVE.org: whether exploitation is observed, whether an attack can be automated, and how much of the system is at stake. The CVSS score shown above comes from the assigning CNA record, not NVD.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via CVEORG
Last analysed / modified upstream
0.6%
1 GitHub repo (last check)
IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker to execute arbitrary code due to improper control of code generation.
langflow_oss >= 1.0.0 <= 1.12.8Upgrade to Langflow OSS 1.13.0 or later. The latest release is available at https://github.com/langflow-ai/langflow/releases . Users deploying via pip may upgrade with: pip install langflow --upgrade. Users deploying via Docker should pull the latest tagged image.
Connected by shared product, vendor, weakness, or advisory.
CVE-2026-110193High· 8.8Langflow OSS is affected by multiple vulnerabilities
CVE-2026-107329Critical· 9.9Langflow OSS is affected by multiple vulnerabilities
CVE-2026-93680Critical· 9.8Langflow OSS is affected by multiple vulnerabilities
CVE-2026-107328Critical· 9.9Langflow OSS is affected by multiple vulnerabilities
CVE-2026-101288High· 8.8Langflow OSS is affected by multiple vulnerabilities
CVE-2026-104328High· 8.8Langflow OSS is affected by multiple vulnerabilities